A free, open-source scanner that checks whether your PHP is affected by CVE-2026-109618 and CVE-2026-109619 — two critical, unauthenticated remote code execution bugs in PHP core. Works even when the PHP version is hidden.
The pair of bugs the whole PHP ecosystem patched on 21 October 2026.
| CVE-2026-109618 | CVE-2026-109619 | |
|---|---|---|
| Type | Out-of-memory memory corruption | Use-after-free |
| Severity | CVSS v4.0 9.2 | CVSS v4.0 9.2 |
| Auth required | None | None |
| Fixed in | PHP 8.2.35, 8.3.36, 8.4.27, 8.5.12 | |
Both bugs live in PHP core itself — not in any application running on top of it. That means login pages, WAF rules and .htaccess deny-lists don't help, since PHP processes the request before any application code runs. It's affected every PHP install from 5.4.0 up to the fixed releases; 7.4, 8.0 and 8.1 only received source backports, not official releases.
No account, no install beyond Python. GUI and command line, both free.
curl to reproduce it.
One-click setup, whatever Python you already have (3.8+, or it'll help you get there).
git clone https://github.com/kunshdeep2812/php2shell-scanner.git
cd php2shell-scanner
python3 setup.py
Then either open the GUI (python3 scanner.py) or scan from the command line:
python3 scanner.py --cli --authorized -t yourdomain.com --deep --oracle
Full docs, options, and safety notes are in the README.
php -v or your package manager on the host, or point php2shell-scanner at the site: python3 scanner.py --cli --authorized -t yourdomain.com --deep --oracle